About JQuery of forumvi

  Bài viết hay nhất1
i want to add bootstrap to my forum but our Fourms has old version of JQuery,
when i change this
<script src="{JQUERY_PATH}" type="text/javascript"></script>
with new path of JQuery i had many problems

how can i solve it
  Bài viết hay nhất2
Use jQuery Migrate.
  Bài viết hay nhất3
do you mean i can replace this
<script src="{JQUERY_PATH}" type="text/javascript"></script>
by
<script src="https://code.jquery.com/jquery-3.0.0.js"></script>
<script src="https://code.jquery.com/jquery-migrate-3.0.0.js"></script>
  Bài viết hay nhất4

@omarpop23 wrote:do you mean i can replace this
<script src="{JQUERY_PATH}" type="text/javascript"></script>
by
<script src="https://code.jquery.com/jquery-3.0.0.js"></script>
<script src="https://code.jquery.com/jquery-migrate-3.0.0.js"></script>
Yes
  Bài viết hay nhất5
i think all problems solved but still one problem

look at this photo


delete button notification_list doesn't work :(

i can send you username and password to inspect this element and see console error
  Bài viết hay nhất6
Try jQuery Migrate 1.x:
Code:
<script src="http://code.jquery.com/jquery-1.12.4.js"></script>
<script src="http://code.jquery.com/jquery-migrate-1.4.1.js"></script>
  Bài viết hay nhất7
still not working i will send username and password to you in PM
  Bài viết hay nhất8
This problem cannot be solved.
Forumotion developers have used jQuery.contains() method improperly.
Code:
if (jQuery.contains($('#' + NOTIF_LIST), e.target)) {
    if ($(e.target).hasClass('delete')) {
        _delItem($('#' + NOTIF_LIST + ' li').index($(e.target).parents('li')), true);
        e.stopPropagation();
        return false
    }
}
The correct usage is: $('#' + NOTIF_LIST)[0]
In jQuery old version (v1.7.2), this bug always returns true. This's a wrong result, but it makes this code work.
In new jQuery version, this bug has been fixed, and it returns false. This code doesn't work.
  Bài viết hay nhất9
oooh, if you were me what should you do ?
please give me some ideas.
  Bài viết hay nhất10
Report this bug with Forumotion. Because they don't allow editing FAToolbar.js file.
  Bài viết hay nhất11
okay i will do my best to report this error

thank you    
  Bài viết hay nhất12
You're welcome.
  Bài viết hay nhất13
woooooooooow yeah

read this

http://help.forumotion.com/t153171-jquery-news-an-update-from-1-7-version-to-3-2-version
  Bài viết hay nhất14
I have inserted this..overall_header
Code:
 <script src="https://code.jquery.com/jquery-3.2.1.min.js"></script>
Does not change anything because ? thank you very much



You cannot reply to topics in this forum