[Tips] jQuery Migrate - Khắc phục lỗi do nâng cấp thư viện jQuery

  Bài viết hay nhất1
Khi mỗi phiên bản jQuery được phát triển, nó được thêm, sửa chữa, hoặc loại bỏ một số API phiên bản trước. Vì thế, một số code sử dụng những API đó sẽ bị lỗi khi bạn nâng cấp thư viện jQuery.
Nếu diễn đàn của bạn có các lỗi như thế, bạn cần bổ sung jquery-migrate. Đây là một plugin của jQuery, được xây dựng cho các phiên bản jQuery 1.9+, giúp đưa các API cũ trở lại.
Xem và tải phiên bản mới nhất của jquery-migrate tại: https://github.com/jquery/jquery-migrate/

Để sử dụng, bạn vào temp overall_header, tìm thư viện jQuery (1.9+) và thêm jquery-migrate vào ngay bên dưới. Ví dụ:
Code:
<script src="//code.jquery.com/jquery-1.10.2.min.js" type="text/javascript"></script>
<script src="//code.jquery.com/jquery-migrate-1.2.1.min.js" type="text/javascript"></script>

Ghi chú: Gần đây nhất, khi mình sử dụng jQuery plugin zzImgUr, đã nâng cấp thư viện jQuery. Việc này làm cho chức năng ajax-profile(cập nhật thông tin ở trang cá nhân) bị lỗi.
Nếu bạn đã nâng cấp thư viện jQuery thì nên bổ sung ngay jquery-migrate.


Zzbaivong
  Bài viết hay nhất2
fix lỗi cho leftslideshow dùng jQ plugin này được không vậy bác
  Bài viết hay nhất3
jquery đã chậm cái này còn làm cho chậm thêm o.O
  Bài viết hay nhất4
@Gdesign wrote:fix lỗi cho leftslideshow dùng jQ plugin này được không vậy bác
Rất tiếc là không, leftslideshow chỉ chạy được phiên bản jQuery 1.4 - 1.7
@Zero wrote:jquery đã chậm cái này còn làm cho chậm thêm o.O
Hi sinh vài mili giây để đổi lấy sự đơn giản, cũng đáng đấy chứ :P
  Bài viết hay nhất5
t thấy nó cũng vậy à :( t dùng ffox
  Bài viết hay nhất6
@phutu01 wrote:t thấy nó cũng vậy à :( t dùng ffox
Chỉ những API bị ảnh hưởng mới thấy "khác vậy".
You cannot reply to topics in this forum